作者 主题:de10-nano jtag破碎? (Read 1492 times)

0会员和1位客人正在查看此主题。

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
de10-nano jtag坏了吗?
« on: 9月20日,2020年,晚上11:06:38»
免责声明:I.'m从中切过来 reddit. since I didn'在那里得到太多回复。希望有人在这里遇到这个问题,可以提供更多的输入。  | O.

我最近有一个Altera De10-Nano Board。所有内容(USB-OTG,远程桌面'进入电路板,串行,LED,加速度计)工作,除了JTAG Mini USB。我在3台计算机上尝试,并在Windows和Linux上。

我首先通过删除SD卡作为指南建议,连接迷你USB电缆,然后插入电路板。

在Windows中,设备管理器中没有新的USB设备。 Quartus Prime没有't detect anything. I'多次尝试过了这一点,并试图安装驱动程序无济于事。我不'甚至得到窗户"device plugged in" sound.

在Linux中,LSUSB或DMESG下没有任何内容。 JTAGCONFIG没有'找到任何东西。我尝试运行它和服务,因为根本无效。它'没有什么都没有插入,就像在Windows中一样。我还肯定会遵循Arch Wiki中的相关指示,以便将其工作,但也失败了。

I've尝试使用msel设置为工厂配置,并包含所有1's. I've还尝试了作为x1模式(10010)没有成功。 JTAG端口出现完全死亡。一世'在港口上验证了连续性,并且至少是港口'凤凰破碎或坏焊接。任何人都知道我可以检查什么,以确保USB Blaster电路ISN't dead?

我缺少电路板上的配置开关的东西,还是刚刚破碎?我不知道什么'错了。请帮忙。
 

离线 特鲁斯

  • 常规贡献者
  • *
  • 帖子:72
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#1开: 9月21日,2020年,07:23:15 AM»
只需特殊即可配置,只需将电源插入电源插孔并插入USB电缆即可进入USB Blaster II Mini USB套接字(HDMI端口旁边的USB电缆)。

在Quartus Prime安装期间,最终有一个提示要求安装USB Blaster II驱动程序,但即使您没有'T选择安装它们,您将看到它在黄色图标下列出"Other devices"在Windows设备管理器中的树。

当设备插入时,我会附上我的设备管理器的图片,如您所在的设备所列出"JTAG cables" tree.

我注意到的一件事是,当USB-OTG微电缆被留下(其他USB插座)时,无法识别USB Blaster II设备。

它看起来像你'已经尝试过,所以我认为你的电路板被打破了,即USB Blaster电路部分've mentioned.
« 上次编辑:2020年9月22日,01:04:11 PM由Tru »
 

离线 大溪文

  • 常规贡献者
  • *
  • 帖子:235
  • 国家: 不
Re:de10-nano jtag坏了?
« 回复#2开: 9月22日,2020年,07:18:32»
如果你不'甚至听到了连接声音或在设备管理器(在Windows中的黄色感叹号(在Windows中)看到一个设备,那么它是USB连接器附近的问题。 USB连接器本身或连接到它的芯片(是FTDI芯片吗?我不'记住)。我首先检查USB连接器上的焊接。
MSEL设置不会影响USB设备和PC主机之间的连接,从而只要您不't看到你不在PC的USB设备'T需要尝试更改这些设置。
 

离线 特鲁斯

  • 常规贡献者
  • *
  • 帖子:72
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#3开: 2020年9月22日,01:11:16 PM»
BTW,原理图可下载:
//www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=205&No=1046&PartNo=4

USB Blaster II部分第10和11页。  There is
1. CY7C68013A(赛普拉斯USB 2.0控制器),提供USB支持
2. EPM570GF100C5N(Altera CLPD),提供USB Blaster II专有Altera JTAG协议

既然你不'甚至得到一个设备连接,我猜赛普拉斯电路部分已经死了。

它看起来有一个JTAG标题,直接连接到CPLD(JTAG控制器),因此绕过USB,但是2x5引脚标头没有焊接。 该标题位于5V电源插孔旁边。
« 上次编辑:2020年9月22日,01:16:15 PM由Tru »
 

离线 Mikerj.

  • 超级贡献者
  • ***
  • 帖子:2692
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#4开: 9月22日,2020年,01:40:41 PM»
你有没有尝试过不同的USB电缆?
 

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
Re:de10-nano jtag坏了?
« 回复#5: 2020年9月22日,08:01:51 PM»
你有没有尝试过不同的USB电缆?

电路板附带的USB电缆与串行端口完美。一世'在电缆和端口上也测试了连续性。那里'据我所知,港口或电缆没有问题。

BTW,原理图可下载:
//www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=205&No=1046&PartNo=4

USB Blaster II部分第10和11页。  There is
1. CY7C68013A(赛普拉斯USB 2.0控制器),提供USB支持
2. EPM570GF100C5N(Altera CLPD),提供USB Blaster II专有Altera JTAG协议

既然你不'甚至得到一个设备连接,我猜赛普拉斯电路部分已经死了。

它看起来有一个JTAG标题,直接连接到CPLD(JTAG控制器),因此绕过USB,但是2x5引脚标头没有焊接。 该标题位于5V电源插孔旁边。

我认为这将是死者的柏树芯片,但我'不确定为什么它会随机到达死亡。我计划尝试购买标准的USB Blaster,但我'自从是doa以来,m将首先尝试返回它。现在,除非我能恢复它我'LL只需使用SD卡。

如果你不'甚至听到了连接声音或在设备管理器(在Windows中的黄色感叹号(在Windows中)看到一个设备,那么它是USB连接器附近的问题。 USB连接器本身或连接到它的芯片(是FTDI芯片吗?我不'记住)。我首先检查USB连接器上的焊接。
MSEL设置不会影响USB设备和PC主机之间的连接,从而只要您不't看到你不在PC的USB设备'T需要尝试更改这些设置。

如上所述'赛普拉斯芯片和我已经测试了USB端口's and cable'连续性。 FTDI芯片位于串口IIRC。

I've也测试了USB 2.0和3.0,这显然没有任何区别。

我认为它'真的死了。如果有人有建议才能恢复/调试柏树芯片会很棒。
 

离线 特鲁斯

  • 常规贡献者
  • *
  • 帖子:72
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#6开启: 2020年9月22日,09:34:00 PM»
在原理图中释放,赛普拉斯使用3.3V。 有一个蓝色的LED,一旦将电源施加到电源插孔,就会亮起,而你的点亮?
 

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
Re:de10-nano jtag坏了?
« 回复#7: 2020年9月22日,09:36:50 PM»
在原理图中释放,赛普拉斯使用3.3V。 有一个蓝色的LED,一旦将电源施加到电源插孔,就会亮起,而你的点亮?

是的。而另一个绿色的LED也像你的照片一样昏暗。从字面上字面上就在董事会(HDMI,串行,电源,USB-OTG,加速度计,GPIO等)外,除了完全死亡的JTAG之外的工作。
 

离线 DMEADS.

  • 常规贡献者
  • *
  • 帖子:150
  • 国家: 我们
  • 当你有555个定时器时,谁需要深入学习
Re:de10-nano jtag坏了?
« 回复#8开: 9月26日,2020年,02:39:29»
我有一个类似的问题,一个de10-lite。

我所有的同学都有同一个董事会,我的是唯一一个笨蛋。与你不同,我会出现,但是当我试图编制它时消失了。当我试图测试连续性时,没有任何通知JTAG链,它表示JTAG ID并没有匹配。

即使我知道电缆很好,我又把它交换出来,我能够在同一问题开始发生之前像5次编程电路板,那么它就不会'T程序再次。如果你真的在捏,我会尝试一堆电缆,即使他们可能只能工作一次或两次。 (也是一条完全重新安装的Quartus曾在很短的时间工作)。基本没有长期修复  | O.

大学教师'甚至尝试询问关于英特尔论坛的问题,浪费时间。我很确定我的问题是USB-Blaster芯片。
 

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
Re:de10-nano jtag坏了?
« 回复#9: 11月30日,2020年,04:44:39»
我回到了这个板上搞砸了。 JTAG.'无论我尝试的USB电缆如何,都死了。我尝试了一个中国USB Blaster下一个(IC被打磨。PCB是蓝色的,它有FYDK。)在我刚填充的JTAG标题上也失败了。 jtagconfig -d返回
代码: [选择]
Unable to read device chain - JTAG chain broken
Quartus同样可以't检测任何设备和JTAG链调试器给予无益
代码: [选择]
Error: JTAG chain problem detected
Error: No device detected
中国的闪客出现在设备经理中,并接受了Quartus驱动程序。一世'在JTAG电缆上还经过验证的连续性& header.

我听说过一些其他陶瓷板有需要删除的东西,以便使用车载JTAG标题?一世'M在为电路板供电之前连接USB Blaster并打开电源,如果有所不同。 (逆转订单没有区别)

有没有人对那里的地方有任何建议?一世'm开始认为FPGA BGA IC可能无法正确焊接。
 

离线 特鲁斯

  • 常规贡献者
  • *
  • 帖子:72
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#10: 12月3日,2020年,05:54:31»
我看到JTAG链错误消息。 对于JTAG链,HPS和FPGA需要处于闭环(参见附加的PDF的第2页)。 这是PCB没有的遗憾't有电阻器的丝网,但无论如何我've发现了大多数JTAG相关的JTAG,看看附图。

我的电路板上的任何电阻都缺失吗?
他们也必须测量0欧姆。
 

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
Re:de10-nano jtag坏了?
« 回复#11开: 12月5日,2020年,12:15:37»
您好,我的电路板与您的董事会相同'在图片中显示。除了标记为DNI之外,没有缺失的电阻。一世'm在印象的印象下,如果我想使用船上的JTAG标题,我应该桥接RN9,这是正确的吗?
 

离线 特鲁斯

  • 常规贡献者
  • *
  • 帖子:72
  • 国家: GB.
Re:de10-nano jtag坏了?
« 回复#12: 12月5日,2020年,03:03:58 PM»
您好,我的电路板与您的董事会相同'在图片中显示。除了标记为DNI之外,没有缺失的电阻。一世'm在印象的印象下,如果我想使用船上的JTAG标题,我应该桥接RN9,这是正确的吗?
哦,是的,dni =没有填充。 不,当我看到它时,RN9是用于连接到USB芯片的JTAG套接字,而这一是'外部JTAG所需的T.在PDF中,JTAG连接器通过RN10连接,该RN10直接转到与EPM570GF100C5N CPLD(板载Blaster)相同的迹线。
JTAG_BLASER_TDI,JTAG_BLASER_TDO,JTAG_BLASER_TMS,JTAG_BLASER_TCK。

唯一用于检查的组件是这两个上拉电阻R26和R27,但我无法在PCB上识别它们。  >:(
« 上次编辑:12月5日,2020年12月,03:07:51 PM由Tru »
 

离线 独立

  • 贡献者
  • 帖子:6
  • 国家: 00
Re:de10-nano jtag坏了?
« 回复#13开启: 2020年12月19日,05:08:58»
你好,我'找到了董事会的图'S布局并位于R26和R27(两者都是如预期的1K欧姆......)

I've附在下面。
« 上次编辑:2020年12月19日,05:16:08 Am由独立事项 »
 


分享我

掘客  Facebook  诽谤  可口的  Technorati.  推特  谷歌  雅虎
SMF.